11 August 2009

Upgrade subclipse in Aptana Studio

At work, we just upgraded to subversion 1.6.3 from 1.4.x and it took us a 1-2 days to solve configuration issues. In order to make our life easier during merges, we decided to go for Aptana Studio. Unfortunately, at the time of this writing, this IDE is bundled with Subclipse 1.4.

Follow these manual steps to upgrade to http://subclipse.tigris.org/update_1.6.x

1. Remove Aptana Subversion Support

  1. Go to About Apanta Studio
    • In your Aptana Studio
      • On Windows, go to Help and select About Aptana Studio
      • On Mac, go to Aptana Studio and select About Aptana Studio
    • In you Eclipse
      • On Windows, go to Help and select About Eclipse SDK
      • On Mac, go to Eclipse and select About Eclipse SDK
  2. Select "Installation Details"
  3. Select the" Installed Software" Tab
  4. Select the plugins you would like to install and click "Uninstall".

2. Install subclipse 1.6.x

  1. From the Help menu, select Install new Software ...
  2. Select Available Software.
  3. Click the Add Site... button.
  4. In the Location text box, type http://subclipse.tigris.org/update_1.6.x
  5. Also add mylyn: http://download.eclipse.org/tools/mylyn/update/e3.4

3. Install Aptana RadRails



Anonymous said...

Thanks much for this.

I wasn't able to follow your steps precisely, because for whatever reason the "Uninstall..." button in my Eclipse "Installation Details" dialog was disabled for all plugins.

I was able to work around that, however, by choosing the "View Plugin Manager" link in the "My Aptana" view, selecting the "Manage" tab, right-clicking the "Aptana Subversion Support" entry, and selecting "Remove" from the context menu. That didn't have the appearance of accomplishing anything immediately, but after restarting Eclipse it was in fact gone.

I then followed your installation instructions for 1.6.x without a hitch. Thanks again!

Nick Ohrn said...

Thanks a bunch for the directions. Like the previous commenter, the Uninstall button was originally greyed out for me. However, after starting up Aptana in Administrator mode (Windows 7) I was able to use the Uninstall button.